News‎ > ‎

Do NOT update to OSX Yosemite

posted Oct 20, 2014, 9:14 AM by Kris Cirillo
Please do not update your system to OSX Yosemite as most of the district laptops are not compatible with it.
Comments